Symbol Font doesn't work

Have a problem? A question? This is the place for answers from other Express users.
Post Reply
hsleff
Posts: 9
Joined: 2004-09-04 15:07:22
Location: Portland, Oregon
Contact:

Symbol Font doesn't work

Post by hsleff »

In Nisus Writer Express v1.2, I cannot get the Symbol font to work. If I select text and then choose Symbol from a Nisus font menu, the text takes on Times formatting. This happens on my Powerebook G4 and also on my wife's iBook (both 12").

For the record, the Symbol font works just fine in my other applications, including TextEdit, Tex-Edit Plus, and (ugh) MS Word.

Is this a known NW Express BUG? Any suggestions?
Harvey
Portland, OR

cchapin
Posts: 419
Joined: 2004-02-25 18:28:40
Location: Maryland, USA

Post by cchapin »

I just now tried to reproduce this on my computer (a 15" G4 PowerBook running OS X 10.3.5).

In Nisus Writer Express 1.1.2, if I change to Symbol from the Font submenu and type, what I type is formatted as Times -- just as it is for you. Once typed, I cannot change the text to symbols by selecting them and changing the font. If I open the Character Palette, change the View to Glyph, change the Font to Symbol and insert characters that way, they come out fine.

I then tried this both ways in TextEdit 1.3 (v202). Same result. I can't seem to "type" the symbols or convert them once typed, but I can insert them from the Character Palette.

I'm not sure why TextEdit works for you and not for me, and since I'm new to Macs, I'm not sure what normal behavior is for Symbol. Can anyone else help?

--Craig

MacSailor
Posts: 290
Joined: 2003-04-03 08:38:41
Location: Linköping, Sweden

Post by MacSailor »

I get the same unwanted result as cchapin gets, both in NWE and TextEdit. Could it be that Symbol is not Unicode and that's the reason it does not behave as it's supposed to do? :?
Peter Edwardsson
..............................

jardar
Posts: 5
Joined: 2004-07-28 14:08:57
Location: Norway

Re: Symbol Font doesn't work

Post by jardar »

Neither in NWE nor in TextEdit am I able to write Roman letters with the Symbol font. As expected, it is also impossible to write Roman letters with another font, and afterwards select the text and change to the Symbol font. In both applications I only get the Times font then (even though TextEdit tries to fool me in the Fonts window). The reason is that Roman letters are not included in the Symbol font. To write Greek letters in MacOS X we are expected to use another keyboard layout, not merely another font.

In Word (both Word X and Word 2004, at least in the 2004 Test Drive version) things are different. And in Word 2004 this even leads to incompatibility with users of Word for Windows. (Again, I have only tried the Test Drive version.) My report can be read here:

http://jardar.nvg.org/mac/word2004.html

I may have misunderstood what you tried to do. :) But maybe you might want to use either the Greek keyboard layout, or my Symbol keyboard layout:

http://jardar.nvg.org/mac/tastatur/index.html#symbol

rmark
Official Nisus Person
Posts: 428
Joined: 2003-02-11 10:49:05
Location: Solana Beach, CA
Contact:

Re: Symbol Font doesn't work

Post by rmark »

Nisus People,

While Nisus Writer Express should continue to use the old OS 9.x (Classic) fonts, Apple has changed the way it handles fonts. I suggest you read about it all on the Apple Web site.


<http://www.apple.com/macosx/pdf/Panthe ... 82003.pdf>
viewing previews of their characters. Managing fonts in Mac OS X Panther is similar to managing music in iTunes. You create collections of fonts (like ...

*******


... <http://www.apple.com/macosx/features/fontbook/>
Get the most from the exquisite selection of resolution-independent fonts in Mac OS X Panther with the new Font Book, which lets you install, preview, search ...


... <http://docs.info.apple.com/article.html?artnum=106417>
Mac OS X has multiple Fonts folders. Where you install a font determines when and who can use it.


Most people who want to use Symbol font want it for Greek (mathematical) characters. To do that in OS X you need to use the Greek input method which will automatically select the Greek range of Lucida Grande (or a similar Unicode font that has the appropriate characters).


I hope this helps.
Write On!
Mark Hurvitz
Nisus Software Inc.

shiraga
Posts: 3
Joined: 2004-09-16 05:51:38

Re: Symbol Font doesn't work

Post by shiraga »

rmark wrote: Most people who want to use Symbol font want it for Greek (mathematical) characters. To do that in OS X you need to use the Greek input method which will automatically select the Greek range of Lucida Grande (or a similar Unicode font that has the appropriate characters).
That's insufficient regarding compatibility of the document.
I have tried four differnt way to input Greek characters and saved both in RTF format and Word (.doc) format. Then, opend by TextEdit and Word to check whether Greek characters are properly displayed.

<ol><li>Insert Greek characters from "character palette" with Symbol font.
<li>Insert Greek characters from "character palette" with Lucida Grande
<li>Typing by using "Greek" Keyboard in combination with "Symbol" font.
<li>Typing by using "Greek" Keyboard in combination with "Lucida Grande" font.</ol>

All looked fine on NWE.
And they are all fine when re-opened by NWE and TextEdit.
However, when the documents (.doc and .rtf) are opened by Word v.X, only 1 and 3 worked.
(i.e., specifying "Symbol" font was necessary.)

I think you should set the font of Greek letters to "Symbol" unless the document is read only by the "Unicode-compatible" application and system.

rallx
Posts: 38
Joined: 2004-09-11 12:05:03

Post by rallx »

It turns out one can use Styles to get around the limitation that Cocoa apps such as Nisus have with typing greek characters. I defined a new character style call "Greek Characters," Set the font to Symbol and set the language of the style to Greek. In Preferences, I choose Keyboard:Greek and check "Switch Keyboard Layouts when language changes." Now, when I want to have greek characters in my text, I just choose "Greek Characters" type the letters I need, and then switch back to basic characters (which is set to use the US keyboard). The only limitation of this is that you have to choose Greek Characters before you type anything. Applying the character style to a letter that you have already typed doesn't do anything (probably because the necessary keyboard switch cannot be done retroactively?). Because this is defined with the Symbol font, the Greek characters appear correctly when opened in a non-Cocoa app such as Word. This gets around the point that hiraga made in the above posting.

Rick

charles
Posts: 481
Joined: 2002-11-26 11:40:35
Location: San Diego, CA
Contact:

Post by charles »

Hi everyone!

As you may know, Nisus Writer Express and TextEdit are fully unicode aware applications. Microsoft Word is only partially unicode aware. This is the source of the issues you are all having.

First of all, it is important to understand why you can no longer simply apply the Symbol font to type greek characters and such. Before unicode, there were only 255 or so characters available, those defined in the ASCII character set. Characters existed for the roman alphabet and a few other symbol and control characters and that was it. If you needed some character that did not exist within this set, you had to use a font like symbol that would actually draw some other glyph, such as the "alpha" symbol, when you typed a normal character, such as an "a".

The problem with ASCII was that while you could see that alpha character, the computer could only see a ASCII character "a", which made it really difficult to write software that worked with more than one language in a single document or that was able to search text properly, etc.

In the 1990's, some big companies came up with a new system for encoding text called Unicode. Unicode has more than 65536 different codes instead of 256, which means that literally every character in every language on the planet can get its own code. This makes possible a whole range of very sophisticated, multilingual applications that have increasing importance in the international world of the Internet.

What this means for you practically is that you now need to enter the actual character you want instead of trying to find a font that will "fake" it. With this information, Nisus Writer Express can determine if the font you have chosen can display that character. If the font cannot display that character, then NWE will automatically find another font as similar as possible to the one you are using that can display the character.

Aside from having to learn this new way of doing things, this approach is actually simpler for you because you no longer need to know anything about what characters a particular font contains; just type want you want in the font you would like it and we will usually get the display as close to what you want as is possible. If you make use of automatic keyboard switching and NWE's exclusive language support, it is even simpler; all you need to do is to is pick your writing language and type away in your automatically chosen keyboard. NWE will do the rest for you.

Now, that is how it works for Unicode aware applications. MS Word is not entirely Unicode aware. That is, it can display unicode characters but it does not do the automatic font substitution you might expect. Even though we try to minimize the times where you might experience this kind of deficiency in Word, the only way to guarantee that everything will still work as you intended, you still need to actually choose a font that will display the character you want to input.

I hope this helps to explain a bit more why NWE behaves as it does in this new world of Unicode.

Cheers,
-Charles
Charles Jolley
Nisus Software, Inc.

shiraga
Posts: 3
Joined: 2004-09-16 05:51:38

Post by shiraga »

rallx wrote:I defined a new character style call "Greek Characters," Set the font to Symbol and set the language of the style to Greek. In Preferences, I choose Keyboard:Greek and check "Switch Keyboard Layouts when language changes." Now, when I want to have greek characters in my text, I just choose "Greek Characters" type the letters I need, and then switch back to basic characters (which is set to use the US keyboard).
It sounds making the things much easier.
I'm going to try it as soon as possigle (I'm not in from o my Mac now).
Thanks ralx!

shiraga
Posts: 3
Joined: 2004-09-16 05:51:38

Post by shiraga »

Hi Charles

I believe that I understand the essential issue between unicode and pre-unicode.

Also, I hope the things become much easier when unicode is available in all the OSs and applications.

However, the reality is that, we should still mind compatibility with non-unicode applications (in spite that they are obsolete) in many occation.

As you see, the current situation is complex enough to confuse some of the users.

Here I suggest two things to make easier to kep documents' compatiblity with the other applications. <ol><li>Putting in FAQ and online help what rallx wrote above.<li>Adding a option to convert Greek letters (which were entered as unicode) into non-unicode letters with Symbol font specification in "Save as..." command (It should be available in Word and WordPerfect formats so on).</ol>

I hope these improvements would let me throw Word into trush at last!

Regards.

rallx
Posts: 38
Joined: 2004-09-11 12:05:03

Post by rallx »

Charles,

Thanks very much for the clarification. I understand that, hypothetically, unicode is better (and for linguists and people who use multiple keyboards, I'm sure that it is), but most of us have had decades of training doing it the "old way." I've been using a Mac since 1984 and NisusWriter classic since the company was called Paragon in 1991. It will take a while for us to get retrained in the brave new world of unicode!

Despite the advantages of Unicode, it still seems to me that, for someone who may use hundreds of greek characters in a single document for math symbols, as I do, the new way is more cumbersome (except using my hint above about character styles). The old way to type the Greek letter alpha:

1. type the letter "a".
2. select the letter and chose symbol font

Steps one and two are completely interchangeable. I would commonly type a whole paragraph with the roman equivalents of the greek characters I needed and then go back and do a non-contiguous selection and change them all at once. The new way (not using character styles):

1. remember ahead of time that you need to insert a Greek letter.
2. Open the OS X Character Palette. If you don't have the keyboards in the menu bar, this requires some digging around to get it.
3. find and select the greek letter that you want in the character palette.
4. Change the font if you want, because you can now type Greek letters in many different fonts.
5. Click the insert button to place the selected character in your document.
6. Repeat steps 3-5 for each Greek letter that you want to insert (unless, of course, you weren't thinking straight and closed the character palette before you were done with...)

I know that as a Cocoa app using the OS X text engine you have no choice but to do it this way. Nisus could, however, ease the transition for all of us trained in the old way by including a "Greek" character style in the New File template of the stock installation.

Rick

MJLew
Posts: 1
Joined: 2004-09-14 20:13:41

Another solution

Post by MJLew »

Here is a solution that makes life very easy in Nisus (although I don’t think it helps Word compatibility):

Open the International System Preference thing (the OS X thing, not a Nisus option), choose the Input Menu tab, and enable the Greek key?board. Click the Options... button and make sure that the top shortcut box is checked. Close the International. Now in Nisus, select your normal keyboard from the OS X keyboard menu thingie, type something, select the Greek keyboard and type some more. Now when you press command-space you will toggle the keyboard between your normal one and Greek. Thus to type a Greek letter you can just press command-space, type the letter and press command-space again to go back to your normal letters.

This solution is using OS X behaviour to help rather than hinder. I don’t know why Nisus can’t give us EXPLICIT instructions in how to make Greeks work instead of just telling us how Apple have made it awkward...

Post Reply