Reply to topic  [ 28 posts ]  Go to page 1, 2  Next
"Couldn't contact Spell Checker" 
Author Message

Joined: 2003-12-04 18:51:11
Posts: 24
I downloaded the Demo version to try it out (being keen to see the back of the Bizzaro-world word monster) and so far it seems ok, but.........

When opening existing Word docs I get the Alert "Couldn't contact Spell Checker", Pressing the OK button does nothing untill it's been hit a dozen times or more, after which it eventually finds it and the doc finishes opening properly.
I gather this is not normal..............?

I have my operating system on it's own partition and the Apps on another and the work on another. I installed NWX and NWT on the apps partition as usual, but the Macros folder was not created in the Library folder in the operating system partition. I subsequently did this manually in an attempt to fix the problem. There is no Library folder in the Apps partition.

Ideas?

ps, as I said; I am keen to leave Word behind, but until tables and other basic word processing fuctions are implemented NWX is not viable for me. :-(
These are a must have.

cheers,
N.

_________________
Nicholas
550MHz TiBk, 512Mb, OS 10.2.8 NWX 2.0


2003-12-04 19:12:49
Profile
Official Nisus Person
User avatar

Joined: 2003-02-11 10:49:05
Posts: 428
Location: Solana Beach, CA
propstuff,

I'm sorry you experience difficulties with Nisus Writer Express.

It seems as though your spelling service has "died." Or, perhaps you have some special spelling dictionaries?

We don't control that code, it's built into the System.

I suggest you restart your Macintosh.

Keep me posted. (You might want to write to <support@nisus.com>.)

_________________
Write On!
Mark Hurvitz
Nisus Software Inc.


2003-12-05 09:24:00
Profile ICQ

Joined: 2003-12-04 18:51:11
Posts: 24
Post 
hello Mark,
I don't think the speller has died because if I keep whacking away at the akert "OK" button for a dozen times or more it eventually finds the speller. (the alert button won't go away until it does)

The problem only occurs on existing word docs, not on new files.

I have tried restarting, using "MacJanitor" to run system maintenance, "Disk Utility" to Repair permissions. but no change.

Having the Macros folder on a different drive partition is not significant??

cheers,
N.

_________________
Nicholas
550MHz TiBk, 512Mb, OS 10.2.8 NWX 2.0


2003-12-05 12:52:49
Profile

Joined: 2003-04-28 07:19:23
Posts: 42
Post 
It stopped working for me too but the process is still running and it works in Mellel.

Mind you, I find it a mild blessing that it doesn't work in NWX. Every time I type a an em dash—like this—it tells me that the "word" it's in is misspelled. In this example that would be "dash—like" and "this—it."


2003-12-06 18:45:27
Profile

Joined: 2003-12-04 18:51:11
Posts: 24
Post 
An Update:

It IS only existing .docs that the speller has trouble with.
So far every existing doc I have has shown the problem, and none of the new files have.

First test
I made a file in NWX, saved it as a .doc, opened it in word, misspelled one word and did a save as .doc (it now defaulted to open in Word instead of NWX)
Opening it in NWX; no problem.

Second test
Made a new file in word, couldn't find the speller. No combination of saving in word, opening and re-savingin NWX etc, etc could be opened in NWX and find the speller.

So the question is: is it a bug, or is it just my machine??

MACROs
The built in macros dont work for me. (see my above posts)
I made a folder on the Apps partition named Library and put the file structure inside it to see if that worked. :-(

I've run out of ideas for this one...............anyone??

HOWEVER
Having looked through NWX a bit now it looks good! As soon as it has Tables as convenient as Wrds, ( and I don't have the blasted "couldn't find spell checker" message come up every 3 seconds), I'll be paying the money:-)

N.

_________________
Nicholas
550MHz TiBk, 512Mb, OS 10.2.8 NWX 2.0


2003-12-08 13:50:17
Profile

Joined: 2002-11-26 11:40:35
Posts: 481
Location: San Diego, CA
Post 
Nicholas:

Let me get this straight: The problem only occurs if you save a file in Word and then try to open in Nisus Writer Express?

It could be the language Word saves the file in that causes Nisus Writer to try to use a different spelling dictionary. Try selecting all of your document and changing the language to something else. (Such as English (U.S.)).

If this is the case, it would work in apps like Mellel and TextEdit because they are not language sensitive.

If you can, send us a file at support@nisus.com that exhibits this problem; it will really help us to track it down.

Thanks,
-Charles


2003-12-08 17:36:37
Profile WWW

Joined: 2003-04-28 07:19:23
Posts: 42
Post 
I just sent you such a document that somebody sent me, which had been prepared in Word for Windows.


2003-12-08 19:55:25
Profile

Joined: 2003-12-04 18:51:11
Posts: 24
Post 
Quote:
Let me get this straight: The problem only occurs if you save a file in Word and then try to open in Nisus Writer Express?


Specificly Charles, it appears that the problem only occurs if it was originaly *authored* in Word.
Authored in NWX, opened, edited and saved in word as a word doc, and reopened in NWX - no prob.
I'll send you one.

btw; any ideas on the Macro problem??

cheers,
N.

_________________
Nicholas
550MHz TiBk, 512Mb, OS 10.2.8 NWX 2.0


2003-12-08 20:39:14
Profile

Joined: 2003-12-04 18:51:11
Posts: 24
Post 
todays update is............

After your comment about different dictionaries Charles, I messed about changing bw UK, US & Aust English dictionaries in NWX and in Word (what a pain that blasted thing is) and now the files which previously couldn't find the speller can. BUT I CAN'T REMEMBER WHICH COMBINATION OF WHAT IT WAS THAT DID THE TRICK!! Sheesh!

Now that that's solved (sic) the next thing is getting the Macros to work.

As I'm on the free demo (26 days to go......) am I entitled to Email Tech support with this one?

cheers,
N.

_________________
Nicholas
550MHz TiBk, 512Mb, OS 10.2.8 NWX 2.0


2003-12-09 22:47:07
Profile
Official Nisus Person
User avatar

Joined: 2003-02-11 10:49:05
Posts: 428
Location: Solana Beach, CA
Please note that this bug has been fixed in the shortly to be released Nisus Writer Express 1.1.1!

We're sorry about the bug, but, thank you all for pointing it out and waiting patiently.

_________________
Write On!
Mark Hurvitz
Nisus Software Inc.


2003-12-11 12:32:36
Profile ICQ

Joined: 2003-12-04 18:51:11
Posts: 24
Post 
Quote:
Please note that this bug has been fixed in the shortly to be released Nisus Writer Express 1.1.1!


Hi again Mark
Do you mean the speller issue has been fixed, or the Macro problem I'm having?

Given that the speller is working, not being able to use macros is still a major problem.
Before installing the demo I was concerned that having the App on a different partition to where the macro folder is supposed to live might be a problem. That seems to be the case.

Again, I'm keen to pay the money, but want to be "sure" that it's going to work for me. ;-O

N.

_________________
Nicholas
550MHz TiBk, 512Mb, OS 10.2.8 NWX 2.0


2003-12-11 13:46:55
Profile

Joined: 2002-11-26 11:40:35
Posts: 481
Location: San Diego, CA
Post 
Hi:

I just realized what question you were asking about with the Macros. The Macros folder should be created inside the Library/Application Support/Nisus Writer/Macros folder of YOUR user folder. In other words, you can go to Home and look in the Library folder there.

But wait! There is an easier way! Open Nisus Writer and select "Open Macros Folder" from the "Macros" menu. This will create the folder at the proper location and open in the Finder for you. I think we changed the Release Notes just recently to reflect this easier way.

Sorry for the confusion.

-Charles

PS. The issue Mark was referring to is the Spelling Dictionaries issue...we modified Nisus Writer so that it will not keep putting up that dialog every time you type a letter.


2003-12-11 23:16:30
Profile WWW

Joined: 2003-12-04 18:51:11
Posts: 24
Post 
Thanks for your reply Charles,

When I installed NWX the folder was not created.

(Remember the App is on a different partition to the Operating system)

I created the folder in the correct place manually and copied the scripts into there. At least I THOUGHT I did :-O

When I opened it via the "open macros" command as you suggested the cupboard was bare.

After putting the macros into the folder (again?) and rebooted NWX, all was good!
Perhaps you might need to look at the installer process for dealing with partitions?

all the best,
looking forward to tables support and such like,

cheers,
N.

_________________
Nicholas
550MHz TiBk, 512Mb, OS 10.2.8 NWX 2.0


2003-12-12 12:49:57
Profile

Joined: 2002-11-26 11:40:35
Posts: 481
Location: San Diego, CA
Post 
propstuff wrote:
Thanks for your reply Charles,

When I installed NWX the folder was not created.
Perhaps you might need to look at the installer process for dealing with partitions?

all the best,
looking forward to tables support and such like,

cheers,
N.


Hi:

I don't think I explained myself clearly enough. It doesn't matter where your application or operating system is. In fact, on my machine my operating system, applications, and user folder are all split into different partitions and everything works just fine.

The problem was that you were installing the Macros in the wrong Library folder. The Library folder you need to use is in your home folder. Not the root Library folder. To explain it another way...this is how it looks on my hard drive. There are two folders:

/Library <- This is where you tried to install
/Users/cjolley/Library <- this is where you should install.

Do you see the difference? As a general convention, any time you see a path beginning with a tilde (~) that means the path is inside your Home folder. (Go there by selecting "Go->Home" from the Finder menu)

Anyway, just using the menu in Nisus Writer is much easier, for sure! :)

-Charles


2003-12-12 13:19:54
Profile WWW

Joined: 2003-12-04 18:51:11
Posts: 24
Post 
Quote:
Do you see the difference?


Ah hah!
I probably didn't read the install instructions well enough.

Quote:
Anyway, just using the menu in Nisus Writer is much easier, for sure!


Indeed!

thanks for the help Charles, and keep up the good work,
Cheers,
N.

_________________
Nicholas
550MHz TiBk, 512Mb, OS 10.2.8 NWX 2.0


2003-12-13 02:35:22
Profile
Display posts from previous:  Sort by  
Reply to topic   [ 28 posts ]  Go to page 1, 2  Next

Who is online

Users browsing this forum: Bing [Bot], Google [Bot] and 4 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB® Forum Software © phpBB Group
Designed by ST Software