Switching languages

Have a problem? A question? This is the place for answers from other Express users.
Post Reply
cchapin
Posts: 419
Joined: 2004-02-25 18:28:40
Location: Maryland, USA

Switching languages

Post by cchapin » 2004-02-25 19:38:36

I'm evaluating Nisus Writer Express and have run into a small issue. I wonder if anyone can set me straight.

In the documents I write, I need to switch between English and Japanese. If I'm writing in English with Times as the font and then switch to a Japanese input method, everything works splendidly: the font automatically changes to a Japanese font. However, when I switch the input method back to English, the font has to be changed manually.

Am I doing something wrong, or is this just the way the program works?

cchapin
Posts: 419
Joined: 2004-02-25 18:28:40
Location: Maryland, USA

Additional information

Post by cchapin » 2004-02-26 11:20:58

I should mention that I'm using a PowerBook with a 1 GHz PowerPC G4 processor and 768 MB DDR SDRAM. I'm running Panther (10.3.2). And I'm using Nisus Writer Express version 1.1.2 as a thirty-day trial.

User avatar
rmark
Official Nisus Person
Posts: 428
Joined: 2003-02-11 10:49:05
Location: Solana Beach, CA
Contact:

Switching languages

Post by rmark » 2004-02-26 15:37:10

To type in multiple languages using Nisus Writer Express:

[This is a general explanation. You can fill your language(s) in as needed.]

1. Choose Preferences from the Nisus Writer Express menu.

2. Click the Languages icon at the top of the Preferences dialog.

3. Scroll along the left column until you find the language in which you want to type (for instance Spanish).

Notice that Nisus Writer Express has automatically filled in certain information. We are aware that there is (as yet) no spelling checker nor thesaurus for Danish (from Apple; you might find what you need at <http://cocoaspell.leuski.net/>. You can select a "secondary font" for displaying text in this language. Because I use the Unicode font Lucida Grande, I choose not to have a secondary font. Notice also that we have selected a keyboard for you.

4. Choose the appropriate keyboard you want to use for typing your text from the Keyboard pop-up menu.

5. Check (or uncheck, as you wish) Switch keyboard layouts when language changes.

You are probably better off with checking this (turning this on).

Be sure to do steps 3. 4., and 5. for each language.

6. Close the Preferences dialog.

7. In your Nisus Writer Express document choose Spanish from the Language submenu of the Format menu or from the pop-up menu in the Language palette.

8. Begin typing.

9. When you want to switch to another language (such as Danish) choose Danish from the pop-up menu in the Language palette.

10. When you want to switch back to English, choose English from the pop-up menu in the Language palette.

Now, when you click your insertion point anywhere in the document it will retain the keyboard input method associated with that language.

However, with all that written, we do not know of any thesauri available for Spanish or Danish.
Write On!
Mark Hurvitz
Nisus Software Inc.

cchapin
Posts: 419
Joined: 2004-02-25 18:28:40
Location: Maryland, USA

The font is the issue

Post by cchapin » 2004-02-26 19:44:38

Thanks for the instructions. I had done all of that but still had the font problem. However, I went back through it again and did one other thing, which seems to have fixed it.

In NWE language preferences, for both English and Japanese, I chose as the secondary font my primary font and checked "Always change to font."

That seemed to do it, though I guess it means that I'll always revert to the same font in every document. I'll have to experiment with this to see whether that's true.

cchapin
Posts: 419
Joined: 2004-02-25 18:28:40
Location: Maryland, USA

Fix was overkill

Post by cchapin » 2004-02-28 19:25:09

Well, the fix I devised enabled me to switch back and forth between English and Japanese easily, but it means I can't use any other fonts besides Times and the Japanese font.

So my original question is still out there. How can I switch the language input method from Japanese to English and switch to an English font at the same time? Is it necessarily a two-step process? As often as I have to switch languages, changing fonts too is going to get tiresome quickly.

cchapin
Posts: 419
Joined: 2004-02-25 18:28:40
Location: Maryland, USA

New fix

Post by cchapin » 2004-03-01 20:08:24

I thought I would mention that I wrote a simple macro for switching from Japanese to English. (My first Nisus macro!) I then assigned it a keystroke. It's not as elegant as just pressing Command-Spacebar, but it will have to do for now.

My original question is still open if anyone has any advice.

User avatar
rmark
Official Nisus Person
Posts: 428
Joined: 2003-02-11 10:49:05
Location: Solana Beach, CA
Contact:

Switching languages

Post by rmark » 2004-03-02 09:05:12

cchapin,

This behavior is an unfortunate artifact of the nature of font substitution in Mac OS X. When you begin typing some characters not supported in the current font, OS X will switch to a font that does support the characters (it will switch to the secondary font first and then, if that does not work, it will switch to something else.) It is possible we will be able to fix this issue in a future release; at the very least Styles will provide a convenient work around for this in the next release.
Write On!
Mark Hurvitz
Nisus Software Inc.

cchapin
Posts: 419
Joined: 2004-02-25 18:28:40
Location: Maryland, USA

Future Font Fix

Post by cchapin » 2004-03-02 12:43:12

Thank you for the explanation. I'm glad to hear that the issue isn't unknown to you. I was afraid it would be too obscure to get attention.

I'll look forward even more to that upcoming release. Depending on how they are implemented, styles might well take care of the problem. I also tested Mellel, which makes styles its centerpiece, and once I had set up a basic English style and a basic Japanese style, I had absolutely no problem switching between them.

My wife is now, as I write, using NWE for the first time. She's Japanese and presumably can be more discriminating about how language switching works. She has had some difficulties, but I'm trying to troubleshoot for her. If I run into a problem I can't solve, I'll post again.

Post Reply