soft hyphen macro

Get help using and writing Nisus Writer Pro macros.
Post Reply
Posts: 1
Joined: 2010-01-29 14:41:56

soft hyphen macro

Post by the-user » 2010-01-29 15:06:40

Just now I downloaded the soft hyphen macro -- a thing I've been longing for for a long time (maybe it has already been there for a long time; I'm new here).

It breaks long words OK, but I don't see a hyphen appear. I've tried a few different fonts, all with the same effect. Am I doing something wrong?

User avatar
Official Nisus Person
Posts: 4251
Joined: 2002-07-11 17:14:10
Location: San Diego, CA

Re: soft hyphen macro

Post by martin » 2010-01-29 15:20:04

Make sure you have enabled hyphenation via the menu View > Allow Hyphenation. That should cause the soft hyphen to become visible when it is used to wrap a line.

User avatar
Posts: 880
Joined: 2007-02-07 00:58:12
Location: Japan

Re: soft hyphen macro

Post by phspaelti » 2010-01-29 17:13:06

Just to flog a dead horse (and beat my own drum 8) ) replace the Nisus repository macro with the macro I provided a few comments ago in this thread. That macro will check and make sure you have hyphenation on.


Post Reply