Reply to topic  [ 6 posts ] 
Curly quotes and fonts 
Author Message

Joined: 2010-10-04 07:12:47
Posts: 11
I usually use curly quotes, but for some things I prefer the dumb quotes, such as for indicating inches or feet. I turned off the "smart punctuation" feature in the Preferences of NWE 3.4, but I could still only type curly quotes. Furthermore, the quotes were correctly inserted for start & end of a quote. I then changed the font away from the one I usually use, which is Palatino. The curly quotes changed to dumb quotes. On the other hand, if I use Palatino with AppleWorks, it will produce dumb quotes, so it's not that Palatino has only curly quotes. What is going on??


2011-09-15 13:58:44
Profile
Official Nisus Person
User avatar

Joined: 2002-07-11 17:14:10
Posts: 4251
Location: San Diego, CA
Actually, the Palatino font is a factor here. That font has an Apple "advanced typography" feature that will smarten straight quotes on screen. In other words, Palatino will (optionally) detect straight quotes and display smart quotes as necessary depending on adjacent characters. Probably AppleWorks is not making use of this feature.

If you want to continue using Palatino, but see the real/straight quotes that you have typed, open Apple's typography panel and turn off "smarten quotes".


2011-09-15 14:27:22
Profile WWW

Joined: 2010-10-04 07:12:47
Posts: 11
Obviously a case where Apple is too smart for my good. The only catch is that I seem to have to turn off the curly quotes in the Typography pane in every document. Is it is possible to make the "off" condition the default in the typography pane, and just use Nisus Expresswriter's controls?


2011-09-23 09:40:56
Profile
Official Nisus Person
User avatar

Joined: 2002-07-11 17:14:10
Posts: 4251
Location: San Diego, CA
Not that I'm aware. I wouldn't expect such a global setting either. You can think of all those typography options like font faces (eg: bold). You wouldn't expect to find an option somewhere that turned off bold for all your documents everywhere.

Do you have Palatino configured as your default font for your "Nisus New File"? If so, you could turn off the curly quote typography option in your Nisus New File's stylesheet, so you at least won't have to adjust new documents you create.


2011-09-23 09:47:44
Profile WWW

Joined: 2010-10-04 07:12:47
Posts: 11
I'm not sure I'm doing what you recommend correctly. In the NWE preferences I selected "New File," and then clicked on the button that showed the default font (Palatino 12.0 pt in my case). The Apple Fonts window appeared. I then selected "Typography…" from the gear box at the bottom, unchecked "Smart Quotes," and closed everything off. I had also previously unchecked "Use smart punctuation…" in the "QuickFix" pane.

I then tested the dumb quotes. I opened a new document and typed a quote. A smart quote was printed, rather than the dumb quote I expected. However, in the Typography pane, the "Smart Quotes" option was unchecked, as it should have been. When I selected the smart quote, checked and unchecked the "Smart Quotes" option, the smart quote changed to a dumb quote. It appears that NWE stores the correct typography option, but only uses it for display purposes in the Typography pane, not when actually printing quotes. Alternatively, I may not have been following your instructions the way you intended.


2011-09-26 07:09:41
Profile
Official Nisus Person
User avatar

Joined: 2002-07-11 17:14:10
Posts: 4251
Location: San Diego, CA
Sorry, my instructions weren't clear on this point. The typography panel has no effect in the preferences window, at least not with the convenience Font button we provide. Here's what to do:

1. Go to the New File preferences pane.
2. Switch to the "Advanced" tab.
3. For your Nisus New File, click the "Open For Editing" button. Your Nisus New File will open as an editable document.
4. In that document window, switch to the stylesheet view.
5. Select the Normal style.
6. Now adjust the font and typography options.
7. Save and close the Nisus New File template document.

That should do it.


2011-09-26 10:07:20
Profile WWW
Display posts from previous:  Sort by  
Reply to topic   [ 6 posts ] 

Who is online

Users browsing this forum: No registered users and 2 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB® Forum Software © phpBB Group
Designed by ST Software