Reply to topic  [ 11 posts ] 
Opening preferences 
Author Message

Joined: 2013-11-10 11:26:17
Posts: 3
Is normal that every time that i launch for the first time Nisus Pro and i click on CM+, to open the prefs, the pref panel opens itself very slowly?
It needs about 5 seconds.

Is it a problem of my mac or a problem/buf of Nisus?

Tks!


2013-11-14 09:58:31
Profile
Official Nisus Person
User avatar

Joined: 2002-07-11 17:14:10
Posts: 4251
Location: San Diego, CA
That isn't normal at all. The preferences window really should load/show itself immediately. To help us diagnose the problem, could you please capture an activity sample during the pause:

1. Launch Apple's utility application "Activity Monitor".
2. In the app listing, select Nisus Writer Pro (NWP).
3. Switch back to NWP and open its preferences.
4. Quickly switch back to Activity Monitor and click the "sample" toolbar button.
5. Save the resulting report and send it to us (either using the menu Help > Send Feedback or email).

One thing: it's important that you capture the sample while NWP is busy loading its preferences. Otherwise we won't learn anything about what's taking so long. Thank you!


2013-11-14 12:50:26
Profile WWW
Official Nisus Person
User avatar

Joined: 2002-07-11 17:14:10
Posts: 4251
Location: San Diego, CA
Are you using Mac OSX 10.9 (Mavericks)? If so, we may have come to understand the problem.


2013-11-18 12:53:55
Profile WWW

Joined: 2013-11-10 11:26:17
Posts: 3
Yes, Mavericks.


2013-11-18 22:20:52
Profile
Official Nisus Person
User avatar

Joined: 2002-07-11 17:14:10
Posts: 4251
Location: San Diego, CA
The problem we've identified with Mavericks is that OSX 10.9, for some reason, takes a much longer time to provide NWP with the little flag icons used in the language listings. If you open your preferences, the Language pane requests those icons from OSX, which takes much longer on OSX 10.9 than it did on OSX 10.8 and earlier. We're going to workaround this problem for our next product update. Sorry for the annoyance in the meantime.


2013-11-19 10:38:00
Profile WWW
User avatar

Joined: 2007-01-17 03:25:42
Posts: 729
Interestingly, this problem does not happen with NWP 1.4.1 on Mavericks.


2013-11-19 10:52:37
Profile
User avatar

Joined: 2006-06-16 16:17:50
Posts: 124
Location: Brighton & Hove, UK
Hamid wrote:
Interestingly, this problem does not happen with NWP 1.4.1 on Mavericks.


It doesn't seem to happen with my NWP 2.0.6. on Mavericks.

_________________
Patrick


2013-11-19 14:05:00
Profile WWW
Official Nisus Person
User avatar

Joined: 2002-07-11 17:14:10
Posts: 4251
Location: San Diego, CA
Hamid wrote:
Interestingly, this problem does not happen with NWP 1.4.1 on Mavericks.

I'm not sure right now why NWP 1.4.1 wouldn't be affected, but we'll have take a look and see what changes might have be responsible. Thanks Hamid.


2013-11-19 22:52:25
Profile WWW
Official Nisus Person
User avatar

Joined: 2002-07-11 17:14:10
Posts: 4251
Location: San Diego, CA
Patrick J wrote:
It doesn't seem to happen with my NWP 2.0.6. on Mavericks.

One factor is which languages you have NWP set to display, and how many. It also only occurs the very first time the language icons need to be shown after launching NWP. After that they are held in memory until you relaunch NWP.


2013-11-19 22:54:04
Profile WWW
User avatar

Joined: 2006-09-25 10:30:11
Posts: 114
Location: Gibraltar, Europe
I sent in a bug report on a similar slow-loading issue a while ago. It happens every time I bring an open NWP Preferences window from the dock, I'm now running NWP 2.0.6 on my Snow Leopard MacMini.

When I sent in the requested Activity Monitor sample file, it didn't help. So I subsequently stopped hiding this window and now always close and reopen it instead. This avoidance means the issue has gone away. :-)

_________________
Find strategies to improve your effectiveness at http://www.lifestrategies.net


Last edited by CrisB on 2013-11-27 00:59:17, edited 1 time in total.



2013-11-22 22:57:34
Profile WWW
Official Nisus Person
User avatar

Joined: 2002-07-11 17:14:10
Posts: 4251
Location: San Diego, CA
These delays in showing the language icons (and opening the preferences) when running on Mac OS X 10.9 should be fixed in the just released Nisus Writer Pro 2.0.7.


2013-11-26 23:24:20
Profile WWW
Display posts from previous:  Sort by  
Reply to topic   [ 11 posts ] 

Who is online

Users browsing this forum: No registered users and 6 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
cron
Powered by phpBB® Forum Software © phpBB Group
Designed by ST Software