Drop down font menu in tooldrawer doesn't work

Have a problem? A question? This is the place for answers from other Express users.
Post Reply
MarioMilosevic
Posts: 10
Joined: 2008-10-14 12:50:18

Drop down font menu in tooldrawer doesn't work

Post by MarioMilosevic » 2013-11-19 16:49:58

I'm running Nisus Writer Express 3.4.5 on an Intel Core MacBook Pro running OSX 10.6.8

The Font menu in the tooldrawer doesn't work. I don't get the little triangle to the right of the name of the font where I can click and get a scrolling drop down menu. I'm stuck with only one font: Times.

I tried starting and restarting NWE and my computer. I tried trashing the font menu cache. I tried getting NWE from another machine, putting it on my machine, and opening my files that way. Nothing worked, the problem still persists. My other applications don't seem to be affected.

Anyone know what's going on? Anyone know what to do about it?

Mario Milosevic

User avatar
martin
Official Nisus Person
Posts: 4258
Joined: 2002-07-11 17:14:10
Location: San Diego, CA
Contact:

Re: Drop down font menu in tooldrawer doesn't work

Post by martin » 2013-11-19 22:48:05

Hi Mario,

One idea: is the character palette perhaps the exact height at which it has switched from its popup-button mode to list/table mode? My guess is that the list mode is active, but only able to display a single font (and no scrollbar).

To test this, try resizing the character palette to be either larger or smaller, using the little "grabber" edge at its bottom:
palette.png
palette.png (20.65 KiB) Viewed 5808 times

MarioMilosevic
Posts: 10
Joined: 2008-10-14 12:50:18

Re: Drop down font menu in tooldrawer doesn't work

Post by MarioMilosevic » 2013-11-20 08:04:35

Hey, thanks, Martin.

I did what you suggested and it didn't exactly fix it, because I still don't have the triangle on the right, but it did open up the window so I could see and select more fonts. It's not back the way it was, but it is now in a state where I can at least use my font library, so I'm grateful for the suggestion.

Mario

User avatar
martin
Official Nisus Person
Posts: 4258
Joined: 2002-07-11 17:14:10
Location: San Diego, CA
Contact:

Re: Drop down font menu in tooldrawer doesn't work

Post by martin » 2013-11-20 11:10:43

Glad to (somewhat) help. Hopefully we can still get you all the way back to using the font list the way you'd like.

Could you please take a screenshot of what you see when the palette is in the condensed mode, when the triangle is missing? It would be best if you could use the menu Help > Send Feedback to send us that screenshot, so we can check if the collected logs indicate any problems (please be sure to enable diagnostics and checkmark the option to "send console log"). Thank you!

User avatar
martin
Official Nisus Person
Posts: 4258
Joined: 2002-07-11 17:14:10
Location: San Diego, CA
Contact:

Re: Drop down font menu in tooldrawer doesn't work

Post by martin » 2013-11-20 16:36:36

MarioMilosevic wrote:I did what you suggested and it didn't exactly fix it, because I still don't have the triangle on the right, but it did open up the window so I could see and select more fonts.
One clarification, in case I didn't relate the information: resizing the palette so it becomes larger will indeed let you see more fonts (as a list), but it won't add back the popup menu. To restore the popup menu, you will need to resize the palette so it becomes smaller; basically reduce the palette height as much as possible, so only one font can be displayed at once.

You may already have understood that, but I just wanted to make sure I was clear on this point.

MarioMilosevic
Posts: 10
Joined: 2008-10-14 12:50:18

Re: Drop down font menu in tooldrawer doesn't work

Post by MarioMilosevic » 2013-11-20 20:20:04

Yay! That fixed it. Just had to resize the box smaller.

Thanks a lot!

Mario

User avatar
martin
Official Nisus Person
Posts: 4258
Joined: 2002-07-11 17:14:10
Location: San Diego, CA
Contact:

Re: Drop down font menu in tooldrawer doesn't work

Post by martin » 2013-11-21 11:51:25

Excellent, I'm glad to hear that!

Post Reply