High CPU usage under Mavericks

Have a problem? A question? This is the place for answers from other Express users.
Post Reply
blazzing
Posts: 4
Joined: 2009-10-08 18:31:21

High CPU usage under Mavericks

Post by blazzing » 2014-03-12 20:45:55

Has anyone else noticed NWE consuming a lot of CPU time under OS X Mavericks? Suddenly my Macbook Pro's battery is only lasting one evening with only NWE and iTunes open. Activity Monitor has me convinced that it's an issue with NWE, it's CPU usage constantly 50-70% of the CPU, even with no documents open. I realize there are plenty of Mavericks-specific 'features' that are already in the works to be fixed, I just haven't seen this mentioned anywhere so I thought I'd bring it up.

blazzing
Posts: 4
Joined: 2009-10-08 18:31:21

Re: High CPU usage under Mavericks

Post by blazzing » 2014-04-18 20:43:29

I think I finally figured this one out... First off, NWE was behaving fine on my wife's Mac, the problem seemed to be with my computer specifically.

I discovered that coreservicesd was eating CPU whenever NWE did. Console would report a steady stream of a message like this:
4/18/14 9:25:20.002 PM coreservicesd[72]: SFLEntryBase::ListHasChanged mach_msg returned 10000004d

I created a new user account and launched NWE from there; again, no problems. Turns out it was something specific to my user account.

This is when I started to get worried; something deep in the depths of my user Library folder seemed to be causing the issue. I haven't found any useful guides to troubleshooting this online aside from the obvious (delete preference files) and the extreme (format hard drive). Migrating all of my mail, addresses, applications, and whatnot to a new user folder isn't a something I'm itching to do.

After running through just about every maintenance activity I could think of (permissions repair, home folder ACL reset, disk repair, reinstall OS X, delete every add-on and plugin, run maintenance scripts, rebuild databases, search for corrupt preferences, search for damaged fonts, clear caches, there's probably more...), I stumbled upon the folder ~/Library/Saved Application State/com.nisus.NisusWriterExpress.savedState. I'd already tried trashing the preference file, this seemed like a decent next step. Lo and behold, it worked!

Long story short:
Problem: NWE was running slowly and killing my battery life
Other symptoms: NWE and coreservicesd were consuming a lot of CPU time, Console was getting flooded with the log message noted above
Solution: deleted the folder ~/Library/Saved Application State/com.nisus.NisusWriterExpress.savedState

I have no idea how I got into this bad state. I just hope this post can help someone else get out of it much faster than I did :wink:

ntx
Posts: 10
Joined: 2006-03-04 08:40:08
Location: tokyo - japan

Re: High CPU usage under Mavericks

Post by ntx » 2014-11-04 03:40:35

Hi blazzing,
I just hope this post can help someone else get out of it much faster than I did
It actually did. Thanks for your valuable information.

Post Reply