Reply to topic  [ 10 posts ] 
All of a sudden problems with Nisus 3.4.X with OS X 10.6 
Author Message

Joined: 2016-08-08 12:37:58
Posts: 7
Recently I have purchased a license for Nisus Writer Pro to use on my new MacBook, where I have OS X 10.10 (El Capitan), and I am very happy with it.

However, a few days ago, when I tried to open Nisus Writer Express on my main computer, where I still use OS X 10.6 (and I never have had a problem), the application quit after a few seconds giving me an EXC_BAD_ACCESS (SIGBUS) with exception codes KERN_PROTECTION_FAILURE at 0x0000000000000000

I have seen this error might be caused by a quite wide range of reasons, so first I checked my RAM (which I upgraded months ago) but it gave me no errors.
I deleted the preference files, but to no avail. Then I tried to install the last supported version of NW Express for 10.6, which is 3.4.6, but it continues to behave in the same way. So I wondered if it could be a software problem.
As far as I recall I haven’t installed anything particular in the last days (I just upgraded Firefox), so I wondered which can be the cause.

That is quite a problem for me, as I could switch to 10.10 on my main computer as well, even if it’s old, but I have things for which I need to run under 10.6 and each time I need to write or open an RTF file I am unable to do so with Nisus. :(

If it can be of help, I will post an example of one of the crash logs I get.

2016-08-08 12:50:07

Joined: 2016-08-08 12:37:58
Posts: 7
Here's an example of a crash log, if someone can help me: :(

Process:         Nisus Writer Express [300]
Path:            /Applications/Nisus Writer Writer Express
Identifier:      com.nisus.NisusWriterExpress
Version:         3.4.6 (0400.0704.01)
Code Type:       X86 (Native)
Parent Process:  launchd [127]

Date/Time:       2016-08-09 10:47:17.816 +0200
OS Version:      Mac OS X 10.6.8 (10K549)
Report Version:  6

Interval Since Last Report:          208317 sec
Crashes Since Last Report:           48
Per-App Interval Since Last Report:  109 sec
Per-App Crashes Since Last Report:   14
Anonymous UUID:                      32B8DDAB-541E-498A-B0BD-35A57C3C6779

Exception Type:  EXC_BAD_ACCESS (SIGBUS)
Exception Codes: KERN_PROTECTION_FAILURE at 0x0000000000000000
Crashed Thread:  0  Dispatch queue:

Thread 0 Crashed:  Dispatch queue:
0         0x99a07dd0 CFStringGetLength + 80
1         0x99a1c38f CFStringCompareWithOptionsAndLocale + 47
2         0x99a1c355 CFStringCompareWithOptions + 53
3         0x99a1c310 CFStringCompare + 64
4               0x954cb624 CompareDescriptorsByTraitsAndPrecedence + 191
5         0x99a6c77f __CFSimpleMergeSort + 591
6         0x99a6c576 __CFSimpleMergeSort + 70
7         0x99a6c576 __CFSimpleMergeSort + 70
8         0x99a6c576 __CFSimpleMergeSort + 70
9         0x99a6c576 __CFSimpleMergeSort + 70
10         0x99a6c598 __CFSimpleMergeSort + 104
11         0x99a6c598 __CFSimpleMergeSort + 104
12         0x99a6c598 __CFSimpleMergeSort + 104
13         0x99a6c38c CFSortIndexes + 252
14         0x99a6c1dd CFQSortArray + 125
15         0x99a4cfe9 CFArraySortValues + 489
16               0x954c804f TCFMutableArray::Sort(long (*)(void const*, void const*, void*), void*) const + 67
17               0x954dd6a1 TCFSetRef::CreateSortedArray(long (*)(void const*, void const*, void*), void*, CFArrayCallBacks const*) const + 161
18               0x954cb547 TFontDescriptorDuplicateFilter::TFontDescriptorDuplicateFilter(__CFSet const*, CFSetCallBacks const*) + 93
19               0x954c7d71 TCollection::CopyMatchingFontDescriptors() + 293
20                 0x97f78702 -[NSFontManager fontDescriptorsInCollection:] + 1000
21  com.nisus.NisusWriterExpress     0x0034c471 -[NTFontListCache runLoopDidIdle] + 171
22  com.nisus.NisusBase              0x3000273a -[NTIdleQueue sendIdleToObject:] + 43
23  com.nisus.NisusBase              0x3000279f -[NTIdleQueue doRun] + 96
24  com.nisus.NisusBase              0x30002007 -[NTIdleQueueScheduler runLoopDidIdleForQueue:] + 47
25  com.nisus.NisusBase              0x300021f8 _NTCarbonIdleTimerCallback + 75
26              0x91cd5184 IdleTimerVector + 62
27         0x99a3da3b __CFRunLoopRun + 8059
28         0x99a3b3c4 CFRunLoopRunSpecific + 452
29         0x99a3b1f1 CFRunLoopRunInMode + 97
30              0x91c80e04 RunCurrentEventLoopInMode + 392
31              0x91c80bb9 ReceiveNextEventCommon + 354
32              0x91c80a3e BlockUntilNextEventMatchingListInMode + 81
33                 0x97bd1595 _DPSNextEvent + 847
34                 0x97bd0dd6 -[NSApplication nextEventMatchingMask:untilDate:inMode:dequeue:] + 156
35                 0x97e4a1c9 -[NSApplication _realDoModalLoop:peek:] + 720
36                 0x97e49945 -[NSApplication runModalForWindow:] + 273
37  com.nisus.NisusWriterExpress     0x001e47a2 -[NTApplication runModalForWindow:] + 253
38                 0x97e3ecbb -[NSAlert runModal] + 234
39  com.nisus.NisusWriterExpress     0x0035051c -[NWAutomaticAppUpdater detectedUnrunnableUpdateItem:] + 326
40  com.nisus.NisusWriterExpress     0x00350963 -[NWAutomaticAppUpdater bestValidUpdateInAppcast:forUpdater:] + 180
41  org.andymatuschak.Sparkle        0x0092ea33 load_dsa_key + 16935
42  org.andymatuschak.Sparkle        0x0092833b 0x924000 + 17211
43             0x98b2d003 -[NSURLConnection(NSURLConnectionReallyInternal) sendDidFinishLoading] + 84
44             0x98b2cf74 _NSURLConnectionDidFinishLoading + 133
45              0x94b3f5bb URLConnectionClient::_clientDidFinishLoading(URLConnectionClient::ClientConnectionEventQueue*) + 197
46              0x94bb7a74 URLConnectionClient::ClientConnectionEventQueue::processAllEventsAndConsumePayload(XConnectionEventInfo<XClientEvent, XClientEventParams>*, long) + 306
47              0x94b31ae4 URLConnectionClient::processEvents() + 94
48              0x94b31987 MultiplexerSource::perform() + 183
49         0x99a3e42b __CFRunLoopDoSources0 + 1563
50         0x99a3beef __CFRunLoopRun + 1071
51         0x99a3b3c4 CFRunLoopRunSpecific + 452
52         0x99a3b1f1 CFRunLoopRunInMode + 97
53              0x91c80e04 RunCurrentEventLoopInMode + 392
54              0x91c80bb9 ReceiveNextEventCommon + 354
55              0x91c80a3e BlockUntilNextEventMatchingListInMode + 81
56                 0x97bd1595 _DPSNextEvent + 847
57                 0x97bd0dd6 -[NSApplication nextEventMatchingMask:untilDate:inMode:dequeue:] + 156
58                 0x97b931f3 -[NSApplication run] + 821
59                 0x97b8b289 NSApplicationMain + 574
60  com.nisus.NisusWriterExpress     0x00002a25 start + 53

2016-08-09 00:49:18
User avatar

Joined: 2007-01-17 03:25:42
Posts: 729
piccic wrote:
[...]Then I tried to install the last supported version of NW Express for 10.6, which is 3.4.6, but it continues to behave in the same way. So I wondered if it could be a software problem.[...]

Nisus Writer Express 3.4.6 requires OSX 10.6.6 to 10.10. If you are on 10.6, you should try Nisus Writer Express 3.4.1 which requires OSX 10.4 to 10.7.
You can download Nisus Writer Express 3.4.1 from

2016-08-09 00:56:44

Joined: 2016-08-08 12:37:58
Posts: 7
Hi Amid,
thanks much for the reply. I have the last version, 10.6.8, and the program starts in a regular way (as it did the previous version – I believe it was precisely 3.4.1 or so from which I upgraded in attempt to solve the problem), but in a few seconds it quits… :(

Switching versions complatible with 10.6.X (or throwing away possibly corrupted preference files) does not seem to bear any result.

2016-08-09 14:14:43

Joined: 2016-08-08 12:37:58
Posts: 7
Any other suggestion? :(

Should I try to get in touch with the Support directly?
I'd really need to be able to use the word processor version under 10.6 as I always did.

2016-08-12 06:21:21

Joined: 2016-08-08 12:37:58
Posts: 7
It seems that the crashes stopped after I deleted and reinstalled a few of the previous versions (and all accompanying files), then I wondered if it might have been a few typefaces I recently added to the Fonts folder in my library to be responsible for causing the problem, so I also tried to move these out of the Fonts folder.

Then I re-installed 3.4.6 and it seems the application now works. I then tried to put one of the fonts back again in the Fonts folder and it did not crash.
I will test re-adding more fonts and see…

2016-08-12 06:59:49
Official Nisus Person
User avatar

Joined: 2002-07-11 17:14:10
Posts: 4251
Location: San Diego, CA
Hamid is correct, that you are trying to use a version of Nisus Writer Express on an unsupported version of Mac OS X. Your OSX system version is older than allowed for your chosen version of Express. That said, it may or may not explain your difficulties. Although we don't support the specific versions you're trying to combine, there's nothing that explicitly stops it from working, we just haven't tested. You may or may not be able to get it working.

The crash log you submitted does indicate the problem lies in loading fonts. So if you want to continue to try to get this unsupported configuration working, you might try any of the following:
1. Clear your system font caches.
2. Disable Nisus Writer's WYSIWYG font menu.
3. Disable one or more of your fonts using Apple's Font Book.

2016-09-21 14:39:27
Profile WWW

Joined: 2016-08-08 12:37:58
Posts: 7
Many thanks Martin,
as I said, thankfully I solved the problems by just de-installing and re-installing a few fonts I had installed.

I would have no problem in sticking with the older version (3.4.1) when I am on OSX 10.6, which is still the one I mainly use, but 3.4.6 appears to work just fine even if unsupported.
As I said, the problem I experienced was independent from the release, 3.4.1 did not work as much as 3.4.6, until I just de-installed that typeface and re-installed it later on.
I do not use neither Font Book nor a third party software: I just have the typefaces I use installed manually in my User Fonts folder within my Library.
I also never use WYSIWIG menus.
Out of curiosity, should the problem re-occur, how do you clean up the system font caches? I am used to do it at work where I use FontExplorer, but I have never done it manually via OS.

Thanks much again for the reply – I love Nisus products and it was a nightmare being unable to use it. :)

2016-09-22 09:42:41
Official Nisus Person
User avatar

Joined: 2002-07-11 17:14:10
Posts: 4251
Location: San Diego, CA
I'm very glad that you're up and running with Nisus Writer, however you managed it by shuffling fonts around. It's great to hear that you enjoy using our app :)
piccic wrote:
Out of curiosity, should the problem re-occur, how do you clean up the system font caches?

I haven't done it in a long while, so I can't confirm, but these instructions for clearing font caches seem correct to me, at least for an older system like yours. You could also download a tool like Cocktail, which includes such features.

2016-09-22 10:08:53
Profile WWW

Joined: 2016-08-08 12:37:58
Posts: 7
I bought a license for Nisus Writer Pro for my new MacBook where I have OSX 10.10, but I really don’t like all the versions of the OS since 10.7, so I prefer to keep 10.6 as long as I’ll be able to do so. In this sense, your support for older OSs is a great feature, something one could have taken for granted years ago, not so much now. That’s one of the things that makes for a serious software developer IMO. And by serious I do not mean Apple now… :lol: :cry:

I remember a former computer science teacher of a friend of mine recommending Nisus to me as early as the 1990s – I purchased it much later but he had such words of praise that when I had to decide I remembered it.

Thanks for the instructions on cleaning the font caches.

2016-09-22 11:13:57
Display posts from previous:  Sort by  
Reply to topic   [ 10 posts ] 

Who is online

Users browsing this forum: No registered users and 3 guests

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB® Forum Software © phpBB Group
Designed by ST Software