Save dialog has changed?

Everything related to our flagship word processor.
Post Reply
sethgodin
Posts: 13
Joined: 2006-12-14 09:39:15

Save dialog has changed?

Post by sethgodin » 2016-12-15 05:05:36

I'm using 2.16

Here's how save used to work:
After a few paragraphs, I'd hit SAVE

It would guess the title of the file from the first line I typed. I usually left it that way. Hit save, done.

Here's how it works now:
After a few paragraphs, I hit SAVE

But it has ALREADY saved the file, called UNTITLED (36). So that file exists and if I want to save it with a real name in the right place, I have to hit save as and now have a duplicate.

Can I have it back the old way?

Thank you

Nisus rules.

User avatar
phspaelti
Posts: 941
Joined: 2007-02-07 00:58:12
Location: Japan

Re: Save dialog has changed?

Post by phspaelti » 2016-12-15 07:06:45

I think you have to uncheck "Keep all new files without asking me".
philip

sethgodin
Posts: 13
Joined: 2006-12-14 09:39:15

Re: Save dialog has changed?

Post by sethgodin » 2016-12-15 08:56:49

Thanks. I appreciate the generous reply... hope all is well in Japan

Alas, that's not it:

https://www.dropbox.com/s/8gvmukmtnyxmg ... 6.jpg?dl=0

it's not checked, and it wasn't before.

User avatar
martin
Official Nisus Person
Posts: 4354
Joined: 2002-07-11 17:14:10
Location: San Diego, CA
Contact:

Re: Save dialog has changed?

Post by martin » 2016-12-15 16:26:15

Philip's suspicion was also my first thought. I'm surprised that's not the reason you're seeing the unwanted behavior. If you have that option unchecked (as you do) then this is how it's supposed to work:

1. You write a few paragraphs.
2. The system (macOS) triggers autosave to a temporary file, eg: Untitled (36).
3. You write some more.
4. You explicitly save, which should show a standard save dialog asking you to choose a final location for your file.
5. With the final location decided and saved, the temporary Untitled file is now removed.

I'm not sure why you're seeing different behavior. What version of the system are you using?

sethgodin
Posts: 13
Joined: 2006-12-14 09:39:15

Re: Save dialog has changed?

Post by sethgodin » 2016-12-15 17:11:13

I'm in 10.11.6

what you described is what always happened

UNTIL I upgraded Nisus recently

sigh.

User avatar
martin
Official Nisus Person
Posts: 4354
Joined: 2002-07-11 17:14:10
Location: San Diego, CA
Contact:

Re: Save dialog has changed?

Post by martin » 2016-12-15 18:27:20

I'm not sure what to make of the problem. I just tested on OSX 10.11.6 with the Nisus Writer settings you posted and the problem did not occur: the autosaved Untitled file was removed after successfully saving manually.

Let's start with some obvious things that probably aren't going to solve this, but we should check anyways:

1. Have you restarted your entire computer since installing the new version? The autosave process is a joint effort, and maybe some quirk is preventing the system from properly clearing away the autosaved temp file.

2. Is your Document Manager folder location anywhere esoteric? Maybe there's something special about that folder that is preventing the system from clearing the temp file away.

If neither of those suggestions help you and the problem persists, could you please send in a feedback report via the menu Help > Send Feedback? I want to have a look at your console log for any potential errors.

adryan
Posts: 199
Joined: 2014-02-08 12:57:03
Location: Australia

Re: Save dialog has changed?

Post by adryan » 2016-12-15 19:55:19

G’day, all

I haven’t tested this — no point anyway without 10.11 — but could it have something to do with the “Time between autosaves” preference setting in Nisus Writer? I’m just wondering whether Autosave might have kicked in before you got around to performing the first manual Save. Autosave might then just have persisted with the “Untitled” filename.

Just a thought.

Cheers,
Adrian
MacBook Pro (mid-2014)
macOS Sierra 10.12.6
Nisus Writer user since 1996

User avatar
phspaelti
Posts: 941
Joined: 2007-02-07 00:58:12
Location: Japan

Re: Save dialog has changed?

Post by phspaelti » 2016-12-15 21:11:15

It's not like I don't understand what Seth is saying. I have two machines, and until recently one of the two behaved in exactly the way Seth is describing. It would accumulate "Untitled ( n )" files in my Nisus Document folder. I'd have to go back and rename them or resave and delete the old ones, or the number would keep increasing, and my Nisus Document folder would fill with files that had such pointless names. Right now the problem seems to have gone away and I'm no longer sure what fixed it. I thought it was the "Keep all new files without asking me" preference, but I'm no longer sure.

Per Adrian's suggestion, I noticed that Seth has the time between saves set to "automatic". I have mine set to 5 minutes.

Incidentally, if the "Keep all new files without asking me" preference really works like that, it doesn't seem to be useful anymore. Has this preference just been superseded by MacOS Autosave?
philip

User avatar
martin
Official Nisus Person
Posts: 4354
Joined: 2002-07-11 17:14:10
Location: San Diego, CA
Contact:

Re: Save dialog has changed?

Post by martin » 2016-12-15 22:48:05

adryan wrote:I’m just wondering whether Autosave might have kicked in before you got around to performing the first manual Save. Autosave might then just have persisted with the “Untitled” filename.
That's exactly right Adrian, but it should still work out okay. The Untitled file is supposed to be removed when the user chooses an explicit location during a manual save.

User avatar
martin
Official Nisus Person
Posts: 4354
Joined: 2002-07-11 17:14:10
Location: San Diego, CA
Contact:

Re: Save dialog has changed?

Post by martin » 2016-12-15 22:57:25

phspaelti wrote:I have two machines, and until recently one of the two behaved in exactly the way Seth is describing. It would accumulate "Untitled ( n )" files in my Nisus Document folder. I'd have to go back and rename them or resave and delete the old ones, or the number would keep increasing, and my Nisus Document folder would fill with files that had such pointless names.
I think there was a bug that prevented Untitled documents from being cleared away properly, but so far as I know it was a long time ago, maybe around Nisus Writer Pro 2.1.2.
Incidentally, if the "Keep all new files without asking me" preference really works like that, it doesn't seem to be useful anymore. Has this preference just been superseded by MacOS Autosave?
If you have that option enabled, autosaved documents are not named using the "Untitled N" template. Instead the name is generated automatically from the content in the document (eg: by looking at heading styles). So this option actually couldn't be responsible for Seth's unexpected miasma of untitled files.

Personally I never found this option useful, since I make all kinds of transitory files. It's way too much work to manually delete all the files I don't want to keep. But some users wanted this feature at some point, so maybe they still like it.

sethgodin
Posts: 13
Joined: 2006-12-14 09:39:15

Re: Save dialog has changed?

Post by sethgodin » 2016-12-16 04:55:57

Well, it gets weirder.

After Martin suggested a restart, I cursed myself for wasting everyone's time by not restarting before posting.

The restart solved the problem and I went to bed.

This morning, for kicks, I opened a new file, typed a few paragraphs, waited three minutes...

and the problem's back, identically.

Martin, I just sent you a log.

Super weird.

thanks, all, for your help.

User avatar
martin
Official Nisus Person
Posts: 4354
Joined: 2002-07-11 17:14:10
Location: San Diego, CA
Contact:

Re: Save dialog has changed?

Post by martin » 2016-12-16 14:03:06

The fact that restarting your Mac temporarily fixed the problem does reaffirm that this is most likely a system issue. It's responsible for managing files when documents are saved to disk, including the dance that safely clears away autosaved Untitled files after a successful manual save.

My first inclination is to have you reset Nisus Writer's sandbox container. I can't be certain that will fix your issue, but it's cleared up other mysterious file system issues reported by our users. However, a warning that resetting the sandbox container will cause you to lose all customizations and preferences you have in Nisus Writer. If you want to avoid that, you'll need to create a backup of your settings before doing the reset, and then restore the backup afterwards. The exact steps would be:

1. Create a backup of your settings.
2. Reset Nisus Writer's sandbox container.
3. Make sure the problem is gone, and Nisus Writer running with default settings does not have the same problem.
4. Restore your backup settings.

I realize all that is a little involved and will take some time– sorry about that. Before you undertake all those instructions you could try a few other random things that probably won't make a difference, but you never know. Here are some ideas:

1. Change your Document Manager folder location. If you select a new folder in Nisus Writer's preferences, even in a similar location, the system will be forced to create a new access authorization.
2. Use Apple's Disk Utility application to verify your disk.

sethgodin
Posts: 13
Joined: 2006-12-14 09:39:15

Re: Save dialog has changed?

Post by sethgodin » 2016-12-17 17:42:16

Thanks Martin

I went straight to the sandbox reset, decided to save time

problem persists

I can certainly live with it, but wanted you to know.

NisusUser
Posts: 258
Joined: 2011-01-12 05:32:38

Re: Save dialog has changed?

Post by NisusUser » 2016-12-18 06:41:47

Now I've got this problem. Hmmm.

User avatar
martin
Official Nisus Person
Posts: 4354
Joined: 2002-07-11 17:14:10
Location: San Diego, CA
Contact:

Re: Save dialog has changed?

Post by martin » 2016-12-20 14:27:19

I'm sorry the sandbox container reset didn't help. I think in order to pursue this matter any further we'll need to debug it using a special version of Nisus Writer. If anyone experiencing this bug is willing to help, please write us at:
Image

Post Reply