Reply to topic  [ 6 posts ] 
Nisus 2.1.6 using 100% CPU 
Author Message

Joined: 2003-04-26 05:51:07
Posts: 18
I notice for the last few days that NWP is using 33-100% or so of my CPU, while doing nothing at all. (This is not LibreOfficeImporter, which is using 0%) Is this a known bug, or is there anything I can do about it? I'm running a Macbook Pro 15", OS 10.10.5 Yosemite, 16 GB ram.


Thanks,

Nick Cahill


2016-11-08 09:25:26
Profile
Official Nisus Person
User avatar

Joined: 2002-07-11 17:14:10
Posts: 4251
Location: San Diego, CA
Hi Nick: I'm not aware of any outstanding issues that could cause high CPU usage when Nisus Writer should be idle. Could you please capture an Activity Monitor sample of Nisus Writer when it is unexpectedly busy? If you send it to me I'll have a look. You can send the sample via the menu Help > Send Feedback or by email to:
Image

Thanks!


2016-11-08 11:19:55
Profile WWW
Official Nisus Person
User avatar

Joined: 2002-07-11 17:14:10
Posts: 4251
Location: San Diego, CA
Nick sent in his document and we discovered the cause of the unexpected CPU usage: a certain sequence of list items and cross-references triggered constant background updating. The problematic content was a list paragraph with cross-references that referenced the list item for that same paragraph.

Basically list item updates would trigger Nisus Writer to check the cross-references, those cross-reference updates would in turn would trigger updates to the list items, cycling ad infinitum. No actual updates were required or performed, but Nisus Writer would continually check for updates in the background. Nisus Writer should be smart enough to see that no updates are needed, breaking the cycle. Indeed we have code to do just that, but a bug is preventing it from working correctly in this particular case

We'll file this something that needs to get fixed. Thanks for your help Nick!


2016-11-08 17:51:06
Profile WWW
User avatar

Joined: 2007-01-17 03:25:42
Posts: 729
I wonder if setting Automatic Content Update Prefereces (from the Tools:Automatic Content menu) for Cross References to 'When Printing / Saving PDF' will help.


2016-11-09 01:55:27
Profile
Official Nisus Person
User avatar

Joined: 2002-07-11 17:14:10
Posts: 4251
Location: San Diego, CA
That's a clever idea Hamid, and does indeed prevent the unintended CPU usage. Thanks for the good idea!


2016-11-09 11:03:28
Profile WWW

Joined: 2018-01-11 07:02:36
Posts: 1
I am new to this forum but would like to say that I am eternally grateful for your solution to this subject.
I have a 1000+ page document, with many cross references and diagrams. It was getting to the point where I would need several seconds to type just one word and I would crash often. Turning off automatic cross referencing has solved this problem. Thanks again.


2018-01-11 07:13:12
Profile
Display posts from previous:  Sort by  
Reply to topic   [ 6 posts ] 

Who is online

Users browsing this forum: Baidu [Spider] and 2 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
cron
Powered by phpBB® Forum Software © phpBB Group
Designed by ST Software