Reply to topic  [ 4 posts ] 
Auto-format - how do I stop it? 
Author Message

Joined: 2005-06-06 13:54:34
Posts: 6
I never noticed this before, but typing a forward slash immediately after an 'o' or 'l' turns them into Scandinavian-looking accented versions. I've turned off all the quickfix options and use only English - in which these characters should never occur. Where is the option to turn this feature off?


2005-07-04 14:02:22
Profile
Official Nisus Person
User avatar

Joined: 2002-07-11 17:14:10
Posts: 4251
Location: San Diego, CA
Post 
That sounds odd, to verify that you are only using English, check what language is indicated in the "Language" palette. If it does say "English (U.S.)" then perhaps the keyboard layout was switched somehow. To verify that, look to the menubar (the bar that appears at the very top of the screen). Next to the date/time (and volume control) there may be a little flag icon. If there is, verify that it shows the U.S. flag.


2005-07-05 13:26:05
Profile WWW

Joined: 2004-09-17 12:20:27
Posts: 25
Here's the solution that appeared recently in MacWorld's Tips column:

"Problem: The letter O followed by a slash turns into an Ø
If you type the letter O followed by a slash (/), and it turns into the letter Ø, you must be using Palatino, Hoefler, Chicago, or New York in a program like TextEdit, Apple’s Pages, or FileMaker.

...

If you’re in an application that uses the Font panel, you can turn this off:

1. Open the Font panel (command-T).

2. From the Action menu (represented by the gear icon in the lower left of the Font panel), choose Typography.

3. In the Typography panel, expand the Diacritics section (if you don’t have a Diacritics section, select a font—such as Palatino—that offers diacritics).

4. Select Don’t Compose Diacritics.

This turns off the Compose Diacritics option. (A diacritic is a mark, such as an accent, that’s placed above, below, or through a roman character.)

In some programs, like Microsoft Word, this never happens. In others, like FileMaker, it happens, but there’s no Typography panel or equivalent to control it; your only recourse there is to avoid using certain fonts."


2007-10-17 06:57:57
Profile
Official Nisus Person
User avatar

Joined: 2002-07-11 17:14:10
Posts: 4251
Location: San Diego, CA
Post 
Thanks for posting that, I wasn't aware that one could resolve the issue that way.


2007-10-17 13:52:03
Profile WWW
Display posts from previous:  Sort by  
Reply to topic   [ 4 posts ] 

Who is online

Users browsing this forum: No registered users and 2 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB® Forum Software © phpBB Group
Designed by ST Software