Something wrong with links in 2.03?

Get help using and writing Nisus Writer Pro macros.
Post Reply
js
Posts: 229
Joined: 2007-04-12 14:59:36

Something wrong with links in 2.03?

Post by js » 2012-07-31 02:38:44

After installing Nisus 2.03 my links don't work properly any more:
Right click plus "Show linked file in finder" does nothing.
Right click plus "Open link" does what "Show linked file in finder" is supposed to do.

User avatar
martin
Official Nisus Person
Posts: 4251
Joined: 2002-07-11 17:14:10
Location: San Diego, CA
Contact:

Re: Something wrong with links in 2.03?

Post by martin » 2012-07-31 14:19:11

This is a bug in the update, and is something we'll have to fix. It turns out it's triggered by the "localhost" prefix at the start of some links. If you need, you could workaround the problem by clipping it from your links.

For example, if your link URL is:

Code: Select all

file://localhost/Users/js/Desktop/image.jpg
Edit that so it becomes:

Code: Select all

file:///Users/js/Desktop/image.jpg
Sorry for the trouble.

js
Posts: 229
Joined: 2007-04-12 14:59:36

Re: Something wrong with links in 2.03?

Post by js » 2012-08-01 14:41:12

Thank you Martin.
I have many hundreds of those links. I wonder if you could provide a macro that eliminates the word "localhost" from the URL of all links of a file?
Of course it would also be good to know that after your correcting the bug this word will not be necessary again ...

User avatar
martin
Official Nisus Person
Posts: 4251
Joined: 2002-07-11 17:14:10
Location: San Diego, CA
Contact:

Re: Something wrong with links in 2.03?

Post by martin » 2012-08-10 15:52:27

We have fixed this bug in the just released version 2.0.4. Sorry for the trouble in the meantime.

Post Reply